Broken images....

  • Steph 02-12-2017, 02:21 PM
    (02-11-2017, 10:19 PM)Backlash Wrote: Images seem to be spotty for me again. Anyone else been having this issue?


    The thing seems to fall over every so often. I'm adding graphing of stats to try and debug.
  • Steph 02-12-2017, 07:28 PM
    (02-12-2017, 02:21 PM)RX14 Wrote:
    (02-11-2017, 10:19 PM)Backlash Wrote: Images seem to be spotty for me again. Anyone else been having this issue?


    The thing seems to fall over every so often. I'm adding graphing of stats to try and debug.


    I'm noticing a socket leak, so i've set it to restart every 2 hours. I'll try to get a more permenant fix ASAP.
  • malmon 02-24-2017, 06:57 PM
    It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/
  • tn5421 02-25-2017, 12:23 AM
    (02-24-2017, 06:57 PM)malmon Wrote: It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/


    Line 6, /src/camo/config.cr
    Code:
    getter length_limit : Int32 = 5 * MiB

  • malmon 02-25-2017, 05:29 AM
    (02-25-2017, 12:23 AM)tn5421 Wrote:
    (02-24-2017, 06:57 PM)malmon Wrote: It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/


    Line 6, /src/camo/config.cr
    Code:
    getter length_limit : Int32 = 5 * MiB



    Hmm, what an odd thing to have in the code :')
    Though couldn't the proxy just redirect to the original link instead if the size is too big?
  • Steph 02-25-2017, 09:11 AM
    (02-25-2017, 05:29 AM)malmon Wrote:
    (02-25-2017, 12:23 AM)tn5421 Wrote:
    (02-24-2017, 06:57 PM)malmon Wrote: It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/


    Line 6, /src/camo/config.cr
    Code:
    getter length_limit : Int32 = 5 * MiB



    Hmm, what an odd thing to have in the code :')
    Though couldn't the proxy just redirect to the original link instead if the size is too big?


    I'll increase it to 10MiB. Honestly, if your image is 5MiB or larger it's way, way too large already. In the future we'll probably control image embeds much more, at least on mobile, to ensure that loading a single forum thread doesn't eat your whole mobile data allowance.
  • tn5421 02-27-2017, 11:31 PM
    (02-25-2017, 09:11 AM)RX14 Wrote:
    (02-25-2017, 05:29 AM)malmon Wrote:
    (02-25-2017, 12:23 AM)tn5421 Wrote:
    (02-24-2017, 06:57 PM)malmon Wrote: It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/


    Line 6, /src/camo/config.cr
    Code:
     getter length_limit : Int32 = 5 * MiB



    Hmm, what an odd thing to have in the code :')
    Though couldn't the proxy just redirect to the original link instead if the size is too big?


    I'll increase it to 10MiB. Honestly, if your image is 5MiB or larger it's way, way too large already. In the future we'll probably control image embeds much more, at least on mobile, to ensure that loading a single forum thread doesn't eat your whole mobile data allowance.


    I added the PR like the sleazy fuck I am.
  • malmon 02-28-2017, 06:54 PM (Edited 02-28-2017, 08:42 PM)
    Probably a bit off topic, but is it possible to embed an image that bypasses the proxy? I want to put a dynamic image in my sig, but it'll be pointless if it gets cached.

    Also, the 2nd image in my sig times out for some reason. It also doesn't show up in markdown files on GitHub.
  • Clickbait 02-28-2017, 08:57 PM
    being able to bypass the proxy defeats the purpose of having the proxy
  • malmon 02-28-2017, 09:25 PM
    (02-28-2017, 08:57 PM)Clickbait Wrote: being able to bypass the proxy defeats the purpose of having the proxy


    Fair enough, though I'm still not sure why my 2nd image is timing out. URL is https://maciozo.com/dontdelete/np.png
  • malmon 03-03-2017, 02:58 PM
    (02-25-2017, 09:11 AM)RX14 Wrote:
    (02-25-2017, 05:29 AM)malmon Wrote:
    (02-25-2017, 12:23 AM)tn5421 Wrote:
    (02-24-2017, 06:57 PM)malmon Wrote: It seems to not like large images?

    https://u.nya.is/fjthso.jpg

    Returns "Content-Length limit exceeded"

    https://proxy.lewd.sx/ee5d8583bf74d59986...f2e6a7067/


    Line 6, /src/camo/config.cr
    Code:
    getter length_limit : Int32 = 5 * MiB



    Hmm, what an odd thing to have in the code :')
    Though couldn't the proxy just redirect to the original link instead if the size is too big?


    In the future we'll probably control image embeds much more, at least on mobile, to ensure that loading a single forum thread doesn't eat your whole mobile data allowance.


    How much more though? Because even the current setup renders dynamic images useless.
  • Backlash 03-21-2017, 09:54 AM
    Can't see shit, cap'n. Y'all workin' on the image proxy again?
  • malmon 03-21-2017, 04:45 PM
    (03-21-2017, 09:54 AM)Backlash Wrote: Can't see shit, cap'n. Y'all workin' on the image proxy again?


    I feel like this feature has caused more problems than it has solved
  • Steph 03-22-2017, 10:30 AM (Edited 03-22-2017, 10:30 AM)
    (03-21-2017, 04:45 PM)malmon Wrote:
    (03-21-2017, 09:54 AM)Backlash Wrote: Can't see shit, cap'n. Y'all workin' on the image proxy again?


    I feel like this feature has caused more problems than it has solved


    We'd need the feature either way, it's just that this new implementation seems to be subtly broken. I don't know why it's broken because it's essentially impossible to reproduce, but i've made sure to fix the reboot every 2h feature.
  • Backlash 01-08-2018, 10:29 PM
    Am I the only one getting more broken images? I've had to shelve at least two posts just 'cuz I couldn't include the images that went with. :c
  • All in One 01-08-2018, 11:27 PM
    (01-08-2018, 10:29 PM)Backlash Wrote: Am I the only one getting more broken images? I've had to shelve at least two posts just 'cuz I couldn't include the images that went with. :c


    >more


    They're pretty much all ded on my end. Except for sigs.
  • Violets 01-09-2018, 01:20 AM (Edited 01-09-2018, 01:22 AM)
    Everything image related seems quite broken for the most part, going through multiple threads

    This makes going through the barefoot cuties thread a lot harder now :(
  • Steph 01-09-2018, 10:15 AM
    Fixed now, my bad. I introduced a stack overflow error when there was an invalid URL so it kept crashing.

    https://github.com/RX14/camo.cr/commit/9...0964b607be
  • Backlash 02-21-2019, 01:19 AM
    Hey, so this isn't related to broken images, but this bug prevents me from making new topics, so this is the best I can do. Apparently, pomf.is must be under new ownership or something, as attempting to use the detailed reply editor redirects you to an empty page on pomf.is; same for if you'd like to start a new topic.

    Naturally, this is infuriating. @Senko-san , any chance we could get a quick fix?
  • Steph 02-24-2019, 07:21 AM
    (02-21-2019, 01:19 AM)Backlash Wrote: Hey, so this isn't related to broken images, but this bug prevents me from making new topics, so this is the best I can do. Apparently, pomf.is must be under new ownership or something, as attempting to use the detailed reply editor redirects you to an empty page on pomf.is; same for if you'd like to start a new topic.

    Naturally, this is infuriating. @Senko-san , any chance we could get a quick fix?


    Sorry for the delay but it's fixed now >_<
  • Backlash 02-24-2019, 10:31 AM
    (02-24-2019, 07:21 AM)Senko-san Wrote:
    (02-21-2019, 01:19 AM)Backlash Wrote: Hey, so this isn't related to broken images, but this bug prevents me from making new topics, so this is the best I can do. Apparently, pomf.is must be under new ownership or something, as attempting to use the detailed reply editor redirects you to an empty page on pomf.is; same for if you'd like to start a new topic.

    Naturally, this is infuriating. @Senko-san , any chance we could get a quick fix?


    Sorry for the delay but it's fixed now >_<


    No worries! Thaanks qt. <3

    [Image: orig]
  • Yuu 02-25-2019, 08:31 AM
    (02-21-2019, 01:19 AM)Backlash Wrote: Hey, so this isn't related to broken images, but this bug prevents me from making new topics, so this is the best I can do. Apparently, pomf.is must be under new ownership or something, as attempting to use the detailed reply editor redirects you to an empty page on pomf.is; same for if you'd like to start a new topic.

    Naturally, this is infuriating. @Senko-san , any chance we could get a quick fix?


    Spooky. Had to install noscript to block it so I could make posts.
    Good to hear it's fixed.

Create an Account or Log In to Post a Reply

You need to be a member to make a reply.

Create an Account

Sign up for a new account in our community. It's easy!

Join Us

Log In

Already have an account? Log in here!

Log In

Broken images....