Broken images....

  • Biggest_Mike 07-22-2016, 04:56 PM
    Ellu there.

    I've noticed that my signature is broken and don't any images that I post on here.

    I'll post the link to the image in case anyone else is having issues. IMG: Click Here
  • malmon 07-22-2016, 05:19 PM
    (07-22-2016, 04:56 PM)Biggest_Mike Wrote: Ellu there.

    I've noticed that my signature is broken and don't any images that I post on here.

    I'll post the link to the image in case anyone else is having issues. IMG: Click Here


    I can currently see your signature. Though it seems that new images aren't being redirected by herukoapp (or w/e it's called) properly.
  • Clickbait 07-22-2016, 05:22 PM
    our SSL proxy is currently down until next week, which is why any images that are hosted on sites that don't have an SSL cert were broken.
  • malmon 07-22-2016, 05:36 PM
    (07-22-2016, 05:22 PM)Melancholy Wrote: our SSL proxy is currently down until next week, which is why any images that are hosted on sites that don't have an SSL cert were broken.


    That being said, can you guys all see my signature?
  • Biggest_Mike 07-22-2016, 05:39 PM (Edited 07-22-2016, 05:39 PM)
    I can not... @malmon...

    Ok thanks for the info though.
  • Biggest_Mike 07-22-2016, 08:43 PM
    Ok I see my images again... And I still can not see yours malmon.
  • malmon 07-23-2016, 04:30 AM
    (07-22-2016, 08:43 PM)Biggest_Mike Wrote: Ok I see my images again... And I still can not see yours malmon.


    That could be because my image is on a server with a CACert SSL certificate.
  • Steph 07-23-2016, 07:45 AM
    (07-22-2016, 05:36 PM)malmon Wrote:
    (07-22-2016, 05:22 PM)Melancholy Wrote: our SSL proxy is currently down until next week, which is why any images that are hosted on sites that don't have an SSL cert were broken.


    That being said, can you guys all see my signature?


    I can.
  • malmon 07-23-2016, 08:50 AM
    (07-22-2016, 08:43 PM)Biggest_Mike Wrote: Ok I see my images again... And I still can not see yours malmon.


    (07-23-2016, 07:45 AM)RX14 Wrote:
    (07-22-2016, 05:36 PM)malmon Wrote:
    (07-22-2016, 05:22 PM)Melancholy Wrote: our SSL proxy is currently down until next week, which is why any images that are hosted on sites that don't have an SSL cert were broken.


    That being said, can you guys all see my signature?


    I can.


    The inconsistency astounds me
  • seel 07-24-2016, 02:21 AM
    (07-23-2016, 08:50 AM)malmon Wrote:
    (07-22-2016, 08:43 PM)Biggest_Mike Wrote: Ok I see my images again... And I still can not see yours malmon.


    (07-23-2016, 07:45 AM)RX14 Wrote:
    (07-22-2016, 05:36 PM)malmon Wrote:
    (07-22-2016, 05:22 PM)Melancholy Wrote: our SSL proxy is currently down until next week, which is why any images that are hosted on sites that don't have an SSL cert were broken.


    That being said, can you guys all see my signature?


    I can.


    The inconsistency astounds me


    I can't. The inconsistency continues!
  • Clickbait 07-28-2016, 04:37 AM
    our image proxy is back up, thanks to @RX14 setting it up on our new dedi.
  • Hexd 08-05-2016, 10:40 AM
    so images still seem to be broken. look at this thread. https://lewd.sx/t/your-all-time-favourit...image-page
  • malmon 08-05-2016, 10:41 AM
    (08-05-2016, 10:40 AM)Hexd Wrote: so images still seem to be broken. look at this thread. https://lewd.sx/t/your-all-time-favourit...image-page


    Well, the latest ones seem to show up fine
  • Steph 08-05-2016, 06:14 PM
    Sorry dedi restarted and broke shit.
  • malmon 12-25-2016, 02:23 PM (Edited 12-25-2016, 02:25 PM)
    Getting issues again. Except it seems to be a bit hit and miss for me. Some images show, some (including those on nya) don't.

    Edit: oh, now they load. As I said, hit and miss.
  • Steph 12-25-2016, 05:37 PM
    Yes, it's really quite weird. I've turned on logging for the image proxy, so I'll see if I can spot any issues.
  • laifot 12-25-2016, 06:18 PM
    Welp, i changed my sig not a long time ago because of this. :(

    I thought hotlinking from imgur was broken
  • Steph 12-27-2016, 08:48 AM
    Looking at the logs hasn't really shed any light on anything, and debugging anything which can't be reproduced is basically impossible, so I might end up writing my own camo proxy in crystal.
  • Clickbait 12-27-2016, 10:39 PM
    (12-27-2016, 08:48 AM)RX14 Wrote: Looking at the logs hasn't really shed any light on anything, and debugging anything which can't be reproduced is basically impossible, so I might end up writing my own camo proxy in crystal.


    Think it could be something to do with CF?

    Like, what if the image hasn't finished downloading on our server, so it displays a 404 or something? and then cloudflare caches it?
  • FukuchiChiisaia 12-28-2016, 12:54 AM
    Works 'kay on my PC. Try upload to different host :)
  • malmon 12-28-2016, 06:40 AM (Edited 12-28-2016, 06:41 AM)
    (12-27-2016, 10:39 PM)Clickbait Wrote:
    (12-27-2016, 08:48 AM)RX14 Wrote: Looking at the logs hasn't really shed any light on anything, and debugging anything which can't be reproduced is basically impossible, so I might end up writing my own camo proxy in crystal.


    Think it could be something to do with CF?

    Like, what if the image hasn't finished downloading on our server, so it displays a 404 or something? and then cloudflare caches it?


    Seems like odd practice to cache a 404.

    (12-28-2016, 12:54 AM)FukuchiChiisaia Wrote: Works 'kay on my PC. Try upload to different host :)


    Image host doesn't seem to make any difference.
  • Steph 12-28-2016, 01:45 PM
    (12-27-2016, 10:39 PM)Clickbait Wrote:
    (12-27-2016, 08:48 AM)RX14 Wrote: Looking at the logs hasn't really shed any light on anything, and debugging anything which can't be reproduced is basically impossible, so I might end up writing my own camo proxy in crystal.


    Think it could be something to do with CF?

    Like, what if the image hasn't finished downloading on our server, so it displays a 404 or something? and then cloudflare caches it?


    In my experience the problem usually goes away after a refresh actually,.
  • Steph 02-05-2017, 09:15 AM
    I have just deployed a new image proxy for lewd.sx, written in crystal. It's open-source and available here. This is the first part of lewd.sx to be written in crystal (yay!)

    If you see any image errors, you can open the image in a new tab and get a descriptive error message of why the request failed. Usually, it will be because the original URL went missing and is no longer returning an image. If you are sure the original image URL is valid, reply to this thread with the proxy.lewd.sx URL and I'll debug it for you.
  • Backlash 02-11-2017, 10:19 PM
    Images seem to be spotty for me again. Anyone else been having this issue?
  • Loko 02-11-2017, 11:26 PM
    (02-11-2017, 10:19 PM)Backlash Wrote: Images seem to be spotty for me again. Anyone else been having this issue?


    Been having it for a while, but I thought it was just my internet.

Create an Account or Log In to Post a Reply

You need to be a member to make a reply.

Create an Account

Sign up for a new account in our community. It's easy!

Join Us

Log In

Already have an account? Log in here!

Log In

Broken images....